A community in which webmasters can ask for help with topics such as PHP coding , MySQL , IT jobs, web design, IT security.
Current location:homephp forumphp talk in 2008 yearpropel-gen's “convert-conf” target fails - page 1
User InfoPosts
propel-gen's “convert-conf” target fails#1
I'm trying to generate my models from a schema.xml file on OSX 10.5 with the latest versions of PHP & Propel 1.3 & Phing. All the model classes actually get created, then it just dies, right at the last step. I have already tried


chmod -R 777 ./application/config


but that didn't help. I have also tried both


propel-gen ./ reverse


and


propel-gen ./ creole


Both produced the same error. This error:

propel > convert-conf:
[echo] Output file: models-conf.php
[echo] XMLFile: /application/config/runtime-conf.xml
Execution of target "convert-conf" failed for the following reason: pear/data/propel_generator/build-propel.xml:514:20: No valid xmlConfFile specified.
[phingcall] /pear/data/propel_generator/build-propel.xml:514:20: No valid xmlConfFile specified.

Execution of target "main" failed for the following reason:
pear/data/propel_generator/build-propel.xml:94:18: Execution of the target buildfile failed. Aborting.
[phing] pear/data/propel_generator/build-propel.xml:94:18: Execution of the target buildfile failed. Aborting.

BUILD FINISHED


Here is my build.properties file:

propel.project = models
propel.database = mysql
propel.database.encoding = utf8
propel.database.url = mysql:host=localhost;dbname={$myDBName}
propel.database.user = {$myDBuser}
propel.database.password = {$myDBpass}
propel.output.dir = /application
propel.php.dir = ${propel.output.dir}/
propel.sql.dir = ${propel.output.dir}/models/sql
propel.schema.dir = ${propel.output.dir}/config
propel.conf.dir = ${propel.output.dir}/config
propel.phpconf.dir = ${propel.output.dir}/config
propel.addGenericAccessors = true


Any ideas?

posted date: 2008-12-11 00:21:00


Re: propel-gen's “convert-conf” target fails#2
I had made out the solution of this problem. click to view my topic...

hope that hepls.

posted date: 2008-12-11 00:21:01


Re: propel-gen's “convert-conf” target fails#3
I don't know how this happened, but my runtime-conf.xml file had a bad line in it:<datasource id="models"> <!-- this ID must match <database name=""> in schema.xml -->See how it says those things must match? Mine didn't. I must have hit a key when I wasn't paying attention, an accidentally edited it. Matched those up, and the build goes fine now. Phew.

posted date: 2008-12-11 11:38:00


Re: propel-gen's “convert-conf” target fails#4
I found that I had the same problem to resolve it I had to setpropel.runtime.conf.file=runtime-config.xmlin build.properties file.After which it worked perfectly.

posted date: 2010-07-14 08:23:00


select page: « 1 »
Copyright ©2008-2017 www.momige.com, all rights reserved.