A community in which webmasters can ask for help with topics such as PHP coding , MySQL , IT jobs, web design, IT security.
Current location:homephp forumphp talk in 2008 yearUnable to exclude directories from PHPDocumentor - page 1
User InfoPosts
Unable to exclude directories from PHPDocumentor#1
I'm trying to run PHPDocumentor on my WAMPServer setup. It runs fine, but I'd like to exclude certain directories, such as \sqlbuddy\ which don't contain my own code. Ironically, PHPDocumentor appears to be ignoring my --ignore switch. I've tried several ways of expressing the same thing, but with the same result. Below is the command I'm running it with:

php.exe "C:\Users\username\Documents\PhpDocumentor\phpdoc" -t "C:\Program Files\wamp\www\docs" -o HTML:default:default -d "C:\Program Files\wamp\www" --ignore sqlbuddy\ --ignore docs\


Many thanks.

posted date: 2008-12-12 01:42:00


Re: Unable to exclude directories from PHPDocumentor#2
I had made out the solution of this problem. click to view my topic...

hope that hepls.

posted date: 2008-12-12 01:42:01


Re: Unable to exclude directories from PHPDocumentor#3
Which version of phpDocumentor are you using?Because the phpDocumentor 1.4.2 release notes states:This release fixes two Windows-specific bugs, one involving usage of the "--ignore" option, and one involving usage of the @filesource tag.

posted date: 2008-12-15 10:22:00


Re: Unable to exclude directories from PHPDocumentor#4
You might need to change that ignore value to forward slash...Internally, old PHP4-era PhpDocumentor still has some slash-handling of its own, where it tries to make all directory separators read as forward-slashes only. Compound this with the --ignore option values effectively being a regex mask, and it gets easy to see how a backslash (typically an escape char in regexes) can be an insidious cause of unexpected behavior.Try using "--ignore sqlbuddy/" instead, and let us know how that goes.

posted date: 2009-05-16 04:49:00


Re: Unable to exclude directories from PHPDocumentor#5
I had the same problem, but different cause: ignoring more than one directory requires passing a comma-separated list i.e:--ignore sqlbuddy/,docs/

posted date: 2010-11-05 03:07:00


Re: Unable to exclude directories from PHPDocumentor#6
I'm using xampp on windows and had the same problem. I upgraded the phpdoc via PEAR upgrade and still had the problem until I read this advice. This tip worked for me. Comma separate. Use Unix style directory slashes ( ie. / ). The comma separation is not in their official docs.

posted date: 2011-03-30 18:47:00


Re: Unable to exclude directories from PHPDocumentor#7
I had to ignore my Zend folder inside library/Zend and that comma trick was really helpfull. Cheers.

posted date: 2011-04-27 05:24:00


select page: « 1 »
Copyright ©2008-2017 www.momige.com, all rights reserved.