A community in which webmasters can ask for help with topics such as PHP coding , MySQL , IT jobs, web design, IT security.
Current location:homephp forumphp talk in 2008 yearWhy is the Internet Explorer Autocomplete feature disabled for all html forms on my website? - page 1
User InfoPosts
Why is the Internet Explorer Autocomplete feature disabled for all html forms on my website?#1
When Internet Explorers AutoComplete is turned on for Forms the entries for each field in the HTML form should be cached and displayed as a prompt when the user starts entering content into the form the second time around.

On my website the AutoComplete feature is never displayed for any forms that exist on that site. But yet other websites retain and deliver that content without problem.

My site is using PHP as the scripting language and all content is delivered over SSL.

posted date: 2008-12-12 12:35:00


Re: Why is the Internet Explorer Autocomplete feature disabled for all html forms on my website?#2
I had made out the solution of this problem. click to view my topic...

hope that hepls.

posted date: 2008-12-12 12:35:01


Re: Why is the Internet Explorer Autocomplete feature disabled for all html forms on my website?#3
What's your question?

posted date: 2008-12-12 12:37:00


Re: Why is the Internet Explorer Autocomplete feature disabled for all html forms on my website?#4
Do you have autocomplete="off" as an attribute in your form elements?

posted date: 2008-12-12 12:38:00


Re: Why is the Internet Explorer Autocomplete feature disabled for all html forms on my website?#5
Autocomplete is not used in IE when using SSL (which is mentioned in your tags, but not in your question).

posted date: 2008-12-12 12:43:00


Re: Why is the Internet Explorer Autocomplete feature disabled for all html forms on my website?#6
I have determined that the problem is related to the Cache-Headers PHP sends out when the start_session() command is issued and the site is running SSL.I have been able to get a hold of a person on the IE security team at Microsoft and they have confirmed that this is how IE is supposed to work. Here is a direct quote from the email."This is considered a feature of the autocomplete system. Significant code was written to make it behave this way."When session_start(); is issued the default http headers php sends out are a no-cache header. Here is another quote from the Microsoft representitive.If a secure page says "Don't cache me", that's an indication that the data is sensitive, and hence the autocomplete data itself is likely sensitive. Admittedly, it is a simple heuristic. Personally, I think it's a bit silly, but it's been there forever.It's probably a good suggestion to support "autocomplete=on" to override the default heuristic.In order to re-enable the autoComplete feature I had to issue this command in php before the start_session() command:session_cache_limiter ('private, must-revalidate');I'm sure there are other ways of manipulating the header cache-controls to allow the autoComplete to function as well.Here is a link to 3 examples forms I made so you can test with IE.

posted date: 2008-12-12 12:46:00


Re: Why is the Internet Explorer Autocomplete feature disabled for all html forms on my website?#7
Wow thanks for the quick comments guys, I was actually posting this after I found an answer, just so the community has access to it.

posted date: 2008-12-12 12:47:00


Re: Why is the Internet Explorer Autocomplete feature disabled for all html forms on my website?#8
no the autocomplete="off" tag was not being used. There is also a different bug that could prevent autcomplete from working that I will be posting another response on as well. It has to do with autocomplete not working if there is no "submit" button in your form.

posted date: 2008-12-12 12:48:00


Re: Why is the Internet Explorer Autocomplete feature disabled for all html forms on my website?#9
I have adjusted the entry accordingly... is the Question title too long now?

posted date: 2008-12-12 12:54:00


Re: Why is the Internet Explorer Autocomplete feature disabled for all html forms on my website?#10
dgavey - how are your forms being submitted? Microsoft isn't overly clear about this subtle issue, but;YOU HAVE TO SUBMIT YOUR FORMS WITH A SUBMIT BUTTONfor this to work!Unless of course you are like every site out there that likes to design their own forms thank you very much, and thus you'll need this hack to make IE behave.http://webbugtrack.blogspot.com/2007/08/bug-137-ie-autocomplete-hardly-ever.htmlwhich points the KB article here, where MS explains this really odd behavior.

posted date: 2008-12-12 13:21:00


Re: Why is the Internet Explorer Autocomplete feature disabled for all html forms on my website?#11
I was aware of this issue and yes there is a submit button all all my forms, I will update this question in a minute with a link to a demo for all to see.

posted date: 2008-12-12 13:49:00


Re: Why is the Internet Explorer Autocomplete feature disabled for all html forms on my website?#12
if you are satisfied with your own answer, then mark it "Best Answer"

posted date: 2010-03-14 05:42:00


select page: « 1 »
Copyright ©2008-2017 www.momige.com, all rights reserved.