A community in which webmasters can ask for help with topics such as PHP coding , MySQL , IT jobs, web design, IT security.
Current location:homephp forumphp talk in 2009 yearchecked the php.ini file “extension=php_pdo_mysql.dll” enabled but still error - page 1
User InfoPosts
checked the php.ini file “extension=php_pdo_mysql.dll” enabled but still error#1
I(ve checked the php.ini file the extensions are enabled:

extension=php_pdf.dll
extension=php_pdo.dll
extension=php_pdo_firebird.dll
extension=php_pdo_mssql.dll
extension=php_pdo_mysql.dll


but still when i try to open the page it gives the error

500 | Internal Server Error | PropelException
Unable to open PDO connection [wrapped: could not find driver]

what do i need to do now? to eliminate this error

thanks

posted date: 2009-04-07 00:57:00


Re: checked the php.ini file “extension=php_pdo_mysql.dll” enabled but still error#2
I had made out the solution of this problem. click to view my topic...

hope that hepls.

posted date: 2009-04-07 00:57:01


Re: checked the php.ini file “extension=php_pdo_mysql.dll” enabled but still error#3
First of all you should post the code that's causing the trouble.

posted date: 2009-04-07 01:16:00


Re: checked the php.ini file “extension=php_pdo_mysql.dll” enabled but still error#4
In php.ini set the following to check if there(s a problem loading the extensions.display_startup_errors = On

posted date: 2009-04-07 01:18:00


Re: checked the php.ini file “extension=php_pdo_mysql.dll” enabled but still error#5
well i am new to symfony all i did was php symfony propel-generate-crud frontend post Post and tried to open localhost/sf_sandbox/web/frontend_dev.php/post

posted date: 2009-04-07 01:25:00


Re: checked the php.ini file “extension=php_pdo_mysql.dll” enabled but still error#6
Find out which PDO driver you actually need (MySQL, MS SQL...?)Test by instantiating PDO yourself, to avoid errors elsewhere:$db = new PDO((mysql:host=127.0.0.1;dbname=testdb(, (username(, (password();If you still get "could not find driver", now you can be sure that you(re really missing it :)How to install it, if you don(t have it already, depends a lot on your system. On Debian Linux, for example, you need to do apt-get install php5-mysql, which installs mysql, mysqli and pdo_mysql extensions.After you install it, ensure that it(s enabled in php.ini. make sure that you(re editing the correct file - the one that is used by your webserver.Afterwards, to verify the extension was loaded correctly, either:create a script which executes phpinfo(). You should see a PDO section with a key PDO drivers and a value such as "mysql, pgsql", orrun php -m from the command line and you should see pdo_mysql for example.

posted date: 2009-04-07 03:34:00


Re: checked the php.ini file “extension=php_pdo_mysql.dll” enabled but still error#7
The php_pdo_mysql.dll in the extension directory may be trying to load the libmysql.dll or mysql.dll which by default is in the php directory (I think - they are at least in my php directory but I installed it so long ago I can(t remember if they were there by default or if I copied them there). If the php directory is not in your PATH these latter dll(s will not be found and cause the error.I would suggest checking that the libmysql.dll and/or mysql.dll is in your php directory. If so, add your php directory to your system(s PATH and REBOOT your computer. I had the same problem, added the php directory to the system(s path, restarted Apache and the problem wasn(t solved. I needed to reboot before Apache/PHP would find the dll(s in the php directory.An alternative is to copy libmysql.dll and mysql.dll into a directory that is searched by default (is it the Windows directory or maybe the Window\System32 directory). When the php_pdo_mysql.dll is loaded it will then be able to find the dependent dlls.If these two dlls aren(t in your php directory, try downloading and installing MySQL. You may find these dlls in amongst the files installed my the MySQL installer. If you(re using Apache it should be reporting in the error log that it can(t load php_pdo_mysql.dll. If not, maybe it(s reporting some other error on start up. Posting any errors from the log maybe helpful for diagnosis.Hope this helps.

posted date: 2009-04-07 04:23:00


Re: checked the php.ini file “extension=php_pdo_mysql.dll” enabled but still error#8
I(ve had problems in the past where despite the DLL being in the php/ext/ directory and despite the php path being set properly, I had to specify the absolute path to the extension.Check the Apache error logs to see if there was a problem loading the extension

posted date: 2009-04-07 09:51:00


Re: checked the php.ini file “extension=php_pdo_mysql.dll” enabled but still error#9
Are you working with the Command line?Often the command line and the PHP in the browser use different PHP.ini files.Use phpinfo() to check the modules included on the borwserUse PHP -m to see the modules installed via the CLI

posted date: 2009-07-08 06:05:00


Re: checked the php.ini file “extension=php_pdo_mysql.dll” enabled but still error#10
check if php_pdo_mysql.dll is there in your [phpinst]/ext directiory

posted date: 2014-11-24 21:21:00


select page: « 1 »
Copyright ©2008-2017 www.momige.com, all rights reserved.