A community in which webmasters can ask for help with topics such as PHP coding , MySQL , IT jobs, web design, IT security.
Current location:homephp forumphp talk in 2009 yearConsuming a php webservice in visual studio - page 1
User InfoPosts
Consuming a php webservice in visual studio#1
Is it possible to consume a php webservice in visual studio? I have a webservice with a wsdl file created by nusoap, when I try to add the web reference in visual studio the name of the service and the methods show up but it complains that the (wsdl is not a known document type( and the discovery document could not be found.

Any suggestions would be appreciated.

thanks,
Richard

Responses to suggestions:


Well there is no asmx file at the moment, since the .net app is using the functions of the php webservice and not the other way around. Maybe nusoap can create a asmx? I think that is just for the .net side though.
I (m trying with nusoap because it automatically creates the wsdl for you, however I did try the inbuilt soap handing of php first with my own wsdl file but got the same error as with nusoap.
Seems the problem in the end was really my webserver, my files where encoded in utf8 and it didn(t like that. Thanks for the answers though.

posted date: 2009-04-14 03:34:00


Re: Consuming a php webservice in visual studio#2
I had made out the solution of this problem. click to view my topic...

hope that hepls.

posted date: 2009-04-14 03:34:01


Re: Consuming a php webservice in visual studio#3
Any particular reason for using nusoap, now that php comes with a native soap library?

posted date: 2009-04-14 06:34:00


Re: Consuming a php webservice in visual studio#4
Can you post the wsdl somewhere?

posted date: 2009-04-17 11:37:00


Re: Consuming a php webservice in visual studio#5
Here is what I found to use nuSoap with WCF. http://offroadcoder.com/2008/03/23/CallingYourNusoapPHPWebServiceFromWCF.aspx

posted date: 2009-04-17 11:39:00


Re: Consuming a php webservice in visual studio#6
I use the pattern of the code found here. It works for me. Also did you check to the wsdl by browsing to the url of the service? It may be that your service is generating an invalid .wsdl file.

posted date: 2009-04-17 15:35:00


select page: « 1 »
Copyright ©2008-2017 www.momige.com, all rights reserved.